Got a question you need an answer to? Looking for answers to questions other people have already asked? Us the Hover Q&A forum to help each other and get help from us.

Show all All Planned Not planned Completed Answered No status Sort by newest post Newest post Recent activity Votes Comments
Hover Email Service Melissa Wilson 0 comments 0 votes None
Cannot send my email... pax riddle 1 comment 0 votes None
Cannot send emails Maria Speer 1 comment 0 votes None
.link availability? Christian Sullivan 1 comment 0 votes None
Samsung Galaxy 7 Tord Cederlund 1 comment 0 votes None
mail Balazs Kegl 0 comments 0 votes None
Unable to send emails - user not permitted to relay Lisa George 5 comments 0 votes None
External Emails not coming through Adrian Hyland-Smith 1 comment 0 votes None
renewal domain was charged twice Florina Craiu-Botan 1 comment 0 votes None
How long does it typically take to get a response from Hover tech support? David Levin 1 comment 0 votes None
Domains With Umlauts Florian Heiber 1 comment 0 votes None
"repoint your domain"; What does this mean? How do I do it? Alex Ethridge 1 comment 0 votes None
Migrating a co.uk domain to Hover Ian Bennett 1 comment 0 votes None
bill from High resolutions systems Bengt Korswing 1 comment 0 votes None
Forwarding not working :( Cooper Hart 1 comment 0 votes None
HOVER would rather loose customers? Robert Lilly 5 comments 0 votes None
Having problems Jonathan Nelson 1 comment 0 votes None
Blank pages, links not working, dashboard broken Mike Buss 2 comments 0 votes None
Change of e-mail address problem Alex Ethridge 3 comments 0 votes None
CANT FIND MY TRANSFER AUTHORIZATION CODE? Tobias Trujillo 1 comment 0 votes None
Downgrade possible? Hans-Uwe Kolle 3 comments 0 votes None
Hover email address J Donoghue 1 comment 0 votes None
SMTP Timeouts Douglas Hornig 0 comments 0 votes None
directing domain name to bluehost? Charlotte Lumley 0 comments 0 votes None
How do I access the Admin features so that I can receover a deleted email? Shane Powell 0 comments -1 votes None
Cannot send emails from my account Sondre Qvist 6 comments 1 vote None
Webmail Application Header missing options William Sikes 0 comments 0 votes None
480 code for SiteGround Marg Boustead 1 comment 0 votes None
Forward was working fine, now it's not. Shelly Perry 1 comment 0 votes None
account full Egmont Rudolphi 0 comments 0 votes None